Vegetation Shapefile not working

Hello! I’m trying to apply a shapefile of vegetation to my model and it’s not working. I have a shapefile with 100+ polygons that represent one vegetation type. When I try to apply it as an overlay, I keep getting multiple errors that say “No definition: SHP_11”. The number changes. I have the ID number matched to the ID column in the shapefile. It works with a different file that only has 5 polygons. Is it just the number of polygons? It should technically still work since I have the IDs matched.Your help is appreciated. I’ve tried to load the vegetation files in a lot of different configurations, but I keep getting that same error: No definition (of multiple polygons).Thanks!

Hi Christa, can you please tell us which version of EEMS you are using?

We see an issue with EE10.1.5 using the shapefiles with vegetation. We will plan to fix this in the next release of EE10. If it was a smaller number of polygons you could use P2D files, but each polygon would need to be in a different P2D file. We haven’t tested the shapefile approach with such a large number of polygons but it should work once we make the bug fix.

I have 10.1.3. When is the next release slated to come out? Thanks for your answer!

If you need a test case to help resolve the problem, I can help.

It should be released in the next week. We have tested it with some relatively simple cases. If you do have a test case please send it to us at (we won’t use it for any purpose other than testing unless permission is give - promise!).