Unable to load sediment core onto EFDC


I am using EFDC EE10.2.3. I am unable to load the sediment core (.dat) file onto the model interface. The problem is that once I browse, load, and click apply, I first see the core data displayed on another temporary window (enhanced message box, Image 3). When I close that temporary window, instead of loading, the entire EFDC Explorer closes.

The .dat file was created using the 2DH view option for creating sediment cores. Attached is a snapshot of the format (Image 1). All the cores have a single layer of 10 cm initial thickness.

Thank you


  1. .DAT file:

  1. Bed Layer Initialization Window:

  1. Window after loading:

Hi Adithya,
Seems that the format of your sediment core did not correct. The core ID column should not put in the 1st column. Please re-format your file base on the attached image and try assigning again.


Hello nqtrang,

Thank you for your response. I tried inputting it the way you have done too. However, when I go to the 2DH view, it is not updated correctly. I have attached the image of my input file. I have 1 bed layer, 3 particle size classes, and 48 “cores”.


Thank you!


As I am trying to troubleshoot this problem, I noticed that the problem of EFDC Explorer closing abruptly after loading the sediment core file is only happening on my system.

I am working with another core file as input (48 cores, 5 sediment layers, 3 sediment particle size classes) attached here.

On another system, I am able to load the file and run the code. However, on my system (laptop), the Explorer closes automatically after clicking on ‘Apply’ in the sediment bed initialization window. I tried deactivating and reactivating the license, but the problem continues.

Any help is appreciated!

Thank you!

Hi Adithya, thank you for pointing this issue out. We have fixed it and the updated version, 10.3.3 has been posted to our website.