Turbulence Schemes in EFDC Explorer 6

In EFDC Explorer 6, there are several turbulence schemes. They are 0 - Original option, 1 - Galerpin, 2- Kantha and Clayson (1994) and 3- Kantah (2003). However, in EFDC Explorer 5, there were options such as : 0- Orignial form, 1- Original form modified for Dimensional Length scale transport and 2- Buchard’s Modified Closure for dimensional length scale trasnport. In EFDC 5 I was using 0 i.e turbulence option and the model was running fine. Now I am trying to run the model to EFDC Explorer 6 and I tried with all the options. Depending upon the option I choose, I get errors like floating overflow error, floating invalid etc. When I run only the flow, then I do not have any problem. But when I check the temperature simulation, then I encounter error. I checked the input files of temperature also but I was not able to find error. What turbulence option do I need to use in EFDC Explorer 6 to make the model stable ? I checked the time step also. Time step used is 3seconds and in EFDC Explorer 5 with time step 4 model was running fine. It seems like something wrong is going on with the transport options but I don’t know what. Thank you.


Hi John,

There are potentially two reasons for the problem you are experiencing – one is that the latest EFDC_DSI is not fully backwardly compatible with EE5. Please load your EE5 model and save it out within EE6. This will reformat the input files in the correct way for the latest version of EFDC.

Another issue is possibly the changes to RIQMAX limits. In order to change this you should go to the “Hydrodynamics” tab and press the “Modify” button in the “Turbulence Options”. You should then select the “Turbulent Intensity” tab. From here you will be able to select different options in the drop down box “Vertical Turbulence Limiting Options”. In EE6 it is recommended that you select “Limit Length Scale and Limit RIQMAX” for improved model stability. This is covered in more detail in Section of the User Manual.