Setting Temperatures of Stream Inflows at Boundaries

I have inherited a model of a harbour with one open boundary and a number of fresh water inflows around its boundary. At these inflows I want to set salinity as zero and temperature as 25C. At the open ocean boundary I have set Salinity as 35 and Temperature as 20C. The variations I get in salinity look right and the temperature from the open ocean boundary has worked, but the temperature of the fresh water inflows stays at zero.

What I’ve done so far:
I have activated Temperature in “Comp Opts”. In “Boundary” I have no input tables for temperature or salinity. In “Boundary” I have clicked “Edit/Review” to get up the “Boundary ConditionsDefinitions/Groups” box. Within this I edit the different Groups to set the Open Boundary Types Top & Bottom Salinities to 35, and its Top and Bottom Temperature to 20. (This boundary works). For the Flow Boundary Types I set Salinity as a constant 0, and temperature as a constant 25. When the model runs, however, these inflows stay at temperature zero.

Can someone tell me which step(s) I’m leaving out, please?

If you are using constant flows these can only be used with constant temp, conversely if you are using a variable flow (QSER) then you must have a variable temp (TSER). In EE, if you click on Temperature in the “Input table and series” in the “Boundary conditions” tab it will help create this time series for you. You must set at least two point so that it looks like a time series - EE will interpolate between the points.

May I ask a question please. The “two point” means two boundary cell of inflow? Do I need to set two inflow boundary cell they have same inflow time series and same of temperature time series?

No, two points refer to two times in the time series. For example, a time series is shown here:
You need at least two rows, that is two or more different times to have time series that can be read by EFDC.

Boundary cells can all have different inflows and different temperatures.

Thank you! I also have an another question about water temperature time series. When I have set a water temperature time series which have 63 days. After I run the EE, in the 2D view, water temperature has no change, like this. My temperature setting of general is ignore evaporation and rainfall, the setting of surface heat exchange is full heat balance with a variable coeff, which is 1. Do I chose a wrong setting? I have tried many times , the result has no change.