Momentum Correction

Under the Boundary Condition Definitions/Groups window in EFDC there is an option to specify the ‘Momentum Corrector for BC Cells Located on Model Edge’. It states this should be >=0 and <=1, and to set to 1 for GVC approach and 0 for DSI approach. I am wondering why it would be necessary to correct for momentum at the BC cells. One problem I am having is that my calculated discharge at the inflow boundary is slightly different from what is input into the model, even though the model seems to be stable as velocities are not changing with time when using a constant flow for the model. I am wondering if using this momentum corrector option may help to correct for this problem.

Thank you.


I believe your model might have other problems rather than the momentum corrector option. I have used EFDC model for sometime now. I have never changed this momentum corrector option. There may be other issues into your model. So, how different is your calculated discharge than the inflow boundary ? I would advise you not to change the momentum corrector on the boundary.




The input flow is 706m^3/s, and the flow computed in the first row of cells is 721m^3/s. Further downstream it reaches 705.3 m^3/s. I’m not sure if this amount of error is expected. I am currently using a curvilinear grid (the cell size varies slightly within the grid), but have also tried a Cartesian grid which has cells of uniform cell size, and I get a discharge of 697m^3/s in the first row. I am using the flow profile tool for the calculation.

Hi, I think that option of momentum corrector under the Boundary Condition Definitions/Groups window in EFDC_Explorer is set either to 0 or 1. Set to 1 is used the GVC method and set to 0 to use the DSI default values. If you wish to change to your setting values, you should come to the Hydrodynamics/ Modify/ Miscellaneous Tab and change it. More explanation can be found in the User’s Manual at page 5-36 Regards, // Tinh

Thank you,

This is very helpful.