Issues with applying a vegetation polygon file

I have a trial copy of EE 8 and am trying out a hydrodynamic-only model, but I’ve run into a snag. My model has a very simple vegetation layer of two classes that consists of three polygons. When I try to load it, it tells me that my polygons aren’t defined. I have made sure the ID column in the shapefile matches the IDs for the veg classes in the model, but it still says they aren’t defined. I have been in contact with one of the teachers from a recent EE class and he also is having this issue. He said: "I tried it on my computer with EE7.3 and EE8.0 and got the same problem. I convert the shpfile to p2d file (a file format you can find in Appendix B of the EE User Manual) and it did not work either. However, if it has only one polygon, both worked. Please go to and bring this problem to the EE development team. It is a bug and needs to be fixed. " Thanks for your time!

Hi czweig,

Is it possible for you to send your model and the polygon files you used to assign the vegetation classes ? Thanks.

Balanced is the model. The other zip is the vegetation file. Attached files (2 MB) (2 KB) 

It appears you are trying to set multiple classes of vegetation with one shape file. You will need to make two separate shape files, each a single polygon, to set each class. They cannot be combined into one file. You then need to set each area in your model domain for each vegetation class individually with each polygon/shape file.

I actually have a much more complicated shapefile (probably 100 polygons and 4 vegetation classes) that represent different vegetation patches/classes. You’re saying to apply those, I’d have to do it single polygon by polygon?

We have looked more closely at this and see that when applying more complicated vegetation maps with a shape file that there are some bugs in EE. These appear when we use the shape file option rather than a P2D. Thanks for alerting us to it. We plan to fix these in the soon to be released update to EE8.

Okay, thank you!

This issue has been addressed with release of EE8.1. Please see further information on our EE Knowledge Base here: