Floating Overflow Error

I got a problem when I used EFDC to do my lessons.
There is always a problem :floating overflow/floating invalid.
I didn’t find any other problems in my models.
But the only problem is the time step,I must short my time step to a very small data (0.01s).
I don’t know why it is.
This problem has bothered me for a long time.
Please help me with this problem.

Hello XiaRan,

When you get a problem: floating overflow / floating invalid the most likely cause for your error is wrong initial / boundary conditions. What is the grid size range for your model ? The time step 0.01 s is very small but it also depends on the grid size.

So, first please go ahead and check all the values in boundary and initial conditions. Make a check list of all the things to check which would make easier. I am including a simple template to help you find your problem.

1) Input data
[ul]Flow data 1 : checked (no problem) [/ul]
[ul]Flow 1 Temperature: checked (no problem)[/ul]
[ul]Downstream Elevation: checked (no problem)[/ul]
[ul]Downstream Temperature: checked (no problem)[/ul]
[ul]Downstream flow & temperature [/ul]
[ul]Withdrawal and return if specified checked (no problem) Dye concentration also specified[/ul]
[ul]Atmospheric Parameters (aser) : checked (no problem)[/ul]
[ul]Wind (wser): checked (no problem)[/ul]
2) Hydrodynamic Parameters
3) Initial Water surface Elevation : 77.74m
4) Time step : 3 seconds
5) Dimensionless horizontal momentum diff : 0.0025
6) Background / constant horizontal eddy viscosity: 0.0001 m2/s
7) Units of flow from all the Rivers. Sometimes we forget to change the units of flow. I myselft have encountered this problem in the past and got those crazy error “Floating overflow/ floating invalid / floating divided by zero etc”.

After you checked at the end write checked and write any comments so that you can find more information. If there is no problem go to the next section to check.
Let me know if this helps to your problem.


Best Regards,
Janesh Devkota

When I changed my “time step” (I am using 6, tried to lessen it) I received the error “Maximum Iterations exceeded in external solutions.” According to the forum, “It is almost certainly a bad initial condition, failing this it will be due to a bad boundary condition. Changing the time step will not resolve the problem”
I am trying to find the error… Under “Hydrodynamics,” How do I determine the wetting and drying? And the BC Wet Depth?
I am trying to check my initial conditions since I am receiving the “floating overflow error”
Now I am at lost.

Hello armicunanan,

Yes, it is little bit tricky to find the error at first. What is the range of your dx and dy ? What is the time step you tried ? What was the smallest time step you tried ? You may check if your initial water surface elevation is very small or not ? May be you can make one run increasing your initial water surface elevation.

For wetting and drying,
Go to Grid & General --> Under Wetting & Drying choose Flag = “-99”. There are several options . If you hover your mouse over flag textbox, it will show you all the available options. Then you have dry depth, dry step , and wet depth. Make sure your wet depth is greater than your dry depth.

Also on your time series files, check if you have non-numeric characters or not. Sometimes we write 1o for “10”. Check these things and let me know if you can run the model or not.

Janesh Devkota

#rows = 137
Time step tried 6, 5, 5.5 –
I noticed that if I am decreasing the value of the time step, the “time in days” in the dos window decreases. I also got the error “Maximum Iterations exceeded in external solutions” when I used time step= 4.5 on my first model.

I actually made a new Cartesian grid using different UTM coordinated from my first model, since I have read that I should check it.
On my second model; using a new Cartesian grid:

Model Run timing:
#of reference periods=10
Duration of reference period:24 hours

Time step=6.0 time in days=.241
Time step=5.5 time in days=.218
Time step=5.0 time in days=.242
Time step=4.5 time in days=.265
Time step=4.0 time in days=.125
Time step=3.5 time in days=.226
Time step=3.0 time in days=.124

Dept/water surface elevation: average is = 2.6646
Range: .4 to 19
I used “used point measurement gridded” to assign the dept/water surface elevation
I tried to use a constant dept/water surface elevation of 11; time step of 6 time in days is up to .124 only and same “floating overflow” error.

What is your minimum cell size ? To find out the information about cell size information. Please go to viewing options and choose “Bottom Elev”. Then on the top menu find “General Statistics” button. Click on that button and it will ask you “Do you want to use a polygon to select the cells to be used for the statistics ? If not, then EE will use all of the cells in the current view.” Click on No and it will display information on the window.

Please copy the information displayed on that window in the forum.

Also, can you try with time step 1 second to see if it works ?

In you reply above, when you wrote time in days = 0.241, 0.218 what does that mean ? Did it mean model simulation stopped at that time ?

Janesh Devkota

Hi Janesh, Thank you for constantly replying to my queries. Here is the information: Statistics for cells whose centroid is inside the box (287594.0, 1566194.0) and (338414.0, 1610084.0) Bottom Elev @ Time: 0.000 Days Statistics Area: Rectangle Active Cell Records: 9889 Active Cell Area-ha: 89001 Active Cell Min DX: 300 Active Cell Avg DX: 300 Active Cell Max DX: 300 Active Cell Min DY: 300 Active Cell Avg DY: 300 Active Cell Max DY: 300 Active Cell Average: -2.6214 Active Cell Minimum: -12.709 Active Cell Maximum: 2.62 Valid Cell Records: 9889 Valid Cell Area-ha: 89001 Valid Cell Min DX: 300 Valid Cell Avg DX: 300 Valid Cell Max DX: 300 Valid Cell Min DY: 300 Valid Cell Avg DY: 300 Valid Cell Max DY: 300 I tried time step of 1.0 and it stopped running at .074 time in days. The time in days 0.241,0.218 I sent before means that the model stopped at that time. thank you! Armi

Hello Armi,

Looking at the cell statistics I think there is some problem with your boundary conditions. What type of boundary conditions have you used ? Can you upload your model here or somewhere so that I could look what went wrong ? Usually we need small time step when the cell size is small to satisfy courant Freidich levy (CFL) condition but it seems like in your case cell size are reasonable and you don’t need very small time step. Are you simulating just flow ?

I might be able to help you looking at your model.


Hi Janesh,

I gave you a link of my model, for your comments and suggestions. Thank you very much!


Hello Armi,

I checked your model and found that you didn’t specify proper parameters for wetting / drying condition. When I fixed that the model is running fine. I even tried to run the model with 10 second time step and it was running fine.


Hi Janesh,
After reading your dialoge, I want to know what parameters for wetting / drying condition you have changed? Can you take it as an example to explain what parameters are appropriate and what are wrong? I have similar problems too. Thank you very much!



I would suggest you to create a new post rather than asking question on already answered post.

Usually, while using the proper wetting / drying option, you need to specify the appropriate wet depth, dry depth and minimum depth in the cell. These options can be set from EFDC Explorer easily. To initialize the wetting / drying option, you should make sure use the appropriate flag. Usually you can choose -11 for wetting / drying flag. The values of dry depth and wet depth may vary on different applications. Hope this helps.

Janesh Devkota