A serious "BUG"(?) in Time Series Plots of Model Analysis

I run a model to simulate water level. I open the Temperature module. Below is my running history:(1) Run01, I use the observed data of evaporation. However, I find that simulated water level is bad (BUG-2.jpg). Because I am VERY sure about the accuracy of inflow/outflows (it is a highly managed waterbody), so I decided to change the evaporation value, which is described in Run02.(2) Run02, I tried “evaporation options” in Temperature module, and find one appropriate method. So I save Run02 to cover Run01, and rerun this model using this built-in function, and get a good result (BUG-1.jpg).Things go well until now. Some strange things occur when I draw plots using Time Series Comparisons in EE, that is:When I click “Plots” icon, the picture I see is sometimes “BUG-1.jpg”, and “BUG-2.jpg” the other times. I click the icon many times (e.g., yesterday, today) and the figure is changing. Or when I close EE (or the computer) and reopen it, sometimes the figure will change, too.But I didn’t rerun the model, so the model result should be the same one. Why the figure drawed by EE changes randomly (change between modeled result of Run01 or Run02)? I think maybe its because the computer memory strategy or other things, I don’t know.Or maybe its because of my wrong operations? Please help me, because Time series plot tool in EE is helpful for I don’t need to export data manually. What’s more important is that if I have changed the model, but the reslut plot is sometimes unchanged, it will puzzle me a lot.

More details: I tried to plot again. This time, I also export “.dat” file of water level in the Time Series of ViewPlan to compare. I find something maybe useful.(1) Try one. I plot for the first time in “Model Analysis”. Meanwhile, I export “.dat” file of water level in the Time Series of ViewPlan. The figures from two sources (Ⅰ.exported “dat” data; Ⅱ. automatically generated by EE) are the same shown in Fig-a. (2) Try two. I plot for the second time. This time I choose the “Use Existing Model Extractions”, because in “Try One” I didn’t choose it. I also export “.dat” file of water level in the Time Series of ViewPlan. This time, the figure using exported “dat” data is the same as “Try one”, however the figure generated by EE’s Model Analysis Tool becomes different (Fig-b). In fact, right figure in Fig-b is what I want, you can see that simulation result is good. However, according to “dat” file I exported, I am afraid it may not the truth. But I was wondering how EE draw that picture (with some unknown values?)?

I am not sure I fully understand the steps you have taken but we have never seen this kind of phenomenon. Can you please make a short video of the issue? I would recommend you be careful to not mix up your Run1 and Run2 by saving over. I am not sure what you saved over, just the input files or the output files also. Better to just make a new folder using “Create New” in the save operation and save and run the model again. Also, you need to make sure you are linking to the correct data file in the “Time Series Comparison” > “Define/Edit” option.

I guess the problem is not about “Plot” function, it’s because that EE doesn’t calculate proper Evaporation data in Temperature module. I tried many “Evaporation Options”, but it seems the simulated results is all the same, which is impossible (see Nash-Sut in docx below). However, I remember when I changed the evaporation option a few days before, the simulated results changed obviously. The change can be seen by figures, even need not by “statistical coefficient”. Could you tell me why EE calculate every Evaporation methods as a same result? I think maybe I click somewhere incorrectly.Note: I have activated Temperature; I am sure that I have saved the EE project “fully” correctly every time I choose a different Evaporation Method. (I have gotten different simulated results for different evaporation options before, but NOW I don’t know why they are all the same. Please help me)Thank you so much.

We have emailed you an example of some models that use evaporation for you to see how this function works. Without seeing your model it is hard to know where the error is and we are unable to replicate your issue. However, one thing to be aware of is that to save you time by not reprocessing the data each time EE you plot the model calibration, EE will use the most recently processed extraction unless told to reload the data. You can select the “Reload Model Output” as shown attached to force EE to reload the data. This may be related to the problem you are having.